Another problem with greyed E-mail icons

Knowledge exchange related to the VPE Report Engine and PDF Library

Moderator: IDEAL Software Support

Another problem with greyed E-mail icons

Postby Bengt » Thu Jan 30, 2020 2:35 pm

One of my customers had some problems with Office 365. They also had Office 2010 installed on that computer and after uninstalling Office 2010, their problems with Office 365 disappeared. However, the E-mail icons in my DataFlex application using VPE were greyed out.

I suppose it has something with MAPI to do. However, the statement Get DoVpeGetMAPIType to iMapi returns 1 which should mean that extended MAPI is used. Chilkat is used for sending E-mails with G-mail.

I tried to repare Office 365, but it didn’t help. I also tried to find out how to install MAPI without installing Outlook, but I didn’t find any solution to that on Internet. Is the only way to install MAPI to install an old version of Outlook? Someone wrote that the register keys
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\App Paths\OUTLOOK.EXE
and
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\OUTLOOK.EXE
should be present, but they are not on the computer with problems.

Bengt
Bengt
 
Posts: 75
Joined: Fri Jan 27, 2006 5:29 pm

Re: Another problem with greyed E-mail icons

Postby IDEAL Software Support » Thu Jan 30, 2020 9:30 pm

We don't know why you have this problem with MAPI and how it can be solved. This is a question for Office tech support.
IDEAL Software Support
 
Posts: 1555
Joined: Thu Nov 18, 2004 4:03 pm

Re: Another problem with greyed E-mail icons

Postby Bengt » Thu Jan 30, 2020 11:14 pm

I can not see how this could be a queston for Office tech support. What I try to do is to send E-mail without using Outlook.
Bengt
 
Posts: 75
Joined: Fri Jan 27, 2006 5:29 pm

Re: Another problem with greyed E-mail icons

Postby IDEAL Software Support » Fri Jan 31, 2020 9:00 am

Ok, then it is a Chilkat tech support question.
IDEAL Software Support
 
Posts: 1555
Joined: Thu Nov 18, 2004 4:03 pm

Re: Another problem with greyed E-mail icons

Postby Bengt » Fri Feb 07, 2020 1:56 pm

The VPE E-mail icon seems to have been disabled because a Windows default E-mail client had been choosen automatically in Standard programs when they uninstalled Office2010. After choosing Outlook as E-mail client, the VPE E-mail icon was enabled. This was obviously necessary regardless of they didn't use Outlook. They use G-mail. So I would say that this was a VPE problem.
/Bengt
Bengt
 
Posts: 75
Joined: Fri Jan 27, 2006 5:29 pm

Re: Another problem with greyed E-mail icons

Postby IDEAL Software Support » Fri Feb 07, 2020 4:29 pm

I don't understand your explanation. Gmail is not an application, but an e-mail service. So the question is, what software was used to send e-mail, and is this software a Simple MAPI or Extended MAPI client? In the end: What e-mail client is now started, when the e-mail icon of VPE is not greyed?
IDEAL Software Support
 
Posts: 1555
Joined: Thu Nov 18, 2004 4:03 pm

Re: Another problem with greyed E-mail icons

Postby Bengt » Fri Feb 07, 2020 4:57 pm

As far as I understand, there is no E-mail client involved. I use the VPE E-mail button to trigger E-mail sending with Chilkat and I want to do that from the VPE Preview. The E-mail button call OnVpeBeforeMail and from there I call the Chilkat routines for sending the mail. For this to work, the button must be enabled.

When I asked Chilkat about this problem I got this answer:

Chilkat has nothing to do with Office, so it makes no difference what version of Office is installed or if Office is not installed at all. Also, MAPI has nothing to do with it. Chilkat does not use MAPI (and never has). Chilkat communicates with email servers via standard protocols: SMTP, IMAP, POP3.

/Bengt
Bengt
 
Posts: 75
Joined: Fri Jan 27, 2006 5:29 pm

Re: Another problem with greyed E-mail icons

Postby IDEAL Software Support » Fri Feb 07, 2020 5:01 pm

There is no bug in VPE. In order to have Simple MAPI or Extended MAPI configured on the system, a system-wide default e-mail client has to be set in the Windows Control Panel. The client which is selected there needs to support either Simple or Extended MAPI.
IDEAL Software Support
 
Posts: 1555
Joined: Thu Nov 18, 2004 4:03 pm


Return to VPE Open Forum

Who is online

Users browsing this forum: No registered users and 10 guests

cron