License VPE .NET Control

Knowledge exchange related to the VPE Report Engine and PDF Library

Moderator: IDEAL Software Support

License VPE .NET Control

Postby wriedmann » Sat Aug 04, 2018 5:16 pm

Hello Mr. Radde,

I'm using the VPE DLL for years now (since v3.0) with it's C interface.
Now I need it as .NET component, but I have a few problems with its license, it shows always the demo mode, both on my development machine and on other machines.
I have tried to add the licenses.lics to my project, but it gives me a very strange compile error:

Error LC0000: 'Die Datei oder Assembly "C:\WINDOWS\Microsoft.NET\ASSEMBLY\GAC_MSIL\System\v4.0_4.0.0.0__b77a5c561934e089\System.dll" oder eine Abh„ngigkeit davon wurde nicht gefunden. Die Assembly wird von einer Laufzeit erstellt, die aktueller als die derzeit geladene Laufzeit ist, und kann nicht geladen werden.'

And a very strange issue: the licenses.licx file taken from the samples shows a "Version=3.60.0.0", even on my machine with 7.1 installed.

Then I have tried the runtime license as described here: https://www.idealsoftware.com/opensourc ... nsing.html but the problem remains. The .key file is created, but both on my development machine and on another machine the demo stamp shows on the preview.

On my machine there are two VPE 7.1 installations, Professional and Standard, and both were normally installed and registered.

Do you have anyx hint for me, please?

Thank you!

Wolfgang
P.S. I'm expecting a newer VPE version soon, or an offer any form of maintenance contract... It is a long time since I spent the last money on VPE, and it works very well
wriedmann
 
Posts: 23
Joined: Sun Feb 06, 2011 10:11 pm

Re: License VPE .NET Control

Postby wriedmann » Sat Aug 04, 2018 9:54 pm

Hello Mr. Radde,

the compile error is gone - I had an old version of lc.exe in my path.

Wolfgang
wriedmann
 
Posts: 23
Joined: Sun Feb 06, 2011 10:11 pm

Re: License VPE .NET Control

Postby IDEAL Software Support » Mon Aug 06, 2018 7:22 am

So the problem is solved?
IDEAL Software Support
 
Posts: 1543
Joined: Thu Nov 18, 2004 4:03 pm

Re: License VPE .NET Control

Postby wriedmann » Wed Aug 08, 2018 1:27 pm

Hello Mr. Radde,

yes, the licx file is now built into my application.

The runtime license does not works. I have tried to uninstall and reinstall VPE, but was not able to make it work.

Wolfgang

P.S. The register/unregister does not works anymore from the installation program. I needed to use the option to register on another machine (but I have done that using the browser on my own machine).
wriedmann
 
Posts: 23
Joined: Sun Feb 06, 2011 10:11 pm

Re: License VPE .NET Control

Postby IDEAL Software Support » Thu Aug 09, 2018 8:49 am

The code for licensing, which we provide at https://www.idealsoftware.com/opensource/net-licensing.html is working for us and others. I don't know what is going wrong on your side. Did you check with a debugger for exceptions or bad return codes?

Regarding the online activation: an automatic update on our Linux webserver broke the online activation. We will provide a fix for the installer. Until then, use a browser for manual activation, as you did.
IDEAL Software Support
 
Posts: 1543
Joined: Thu Nov 18, 2004 4:03 pm


Return to VPE Open Forum

Who is online

Users browsing this forum: No registered users and 2 guests

cron