Can't load template in 64 bit version

Knowledge exchange related to the VPE Report Engine and PDF Library

Moderator: IDEAL Software Support

Can't load template in 64 bit version

Postby nicolasBBS » Tue Dec 05, 2017 12:02 pm


I have been using VPE 7.10 and Dycodoc templates for a long time on 32 bit applications, and now I have to migrate some of my applications to 64 bits (I have the 32/64 bits bundled enterprise version).
Everything seems to be ok when using direct printing functions like writebox... but I can't reach to load a template file.
This is a very simple code :
VPEngine1.SaveFileName := '*.pdf';
VPEngine1.Compression := DOC_COMPRESS_FLATE;

This code works correctly in 32 bits, but in 64 bits I get a runtime error at the calling of loadTemplate : $C0000090 FLOAT_INVALID_OPERATION.
I don't understand what is wrong...
I have the same result with all my existing tpl files and with a very simple tpl file that I created for this test.
On my developer machine VPE DLLs are into Windows\System32, and on testing machines I place it (the 64 bit version...) into my application's folder. Same result (and if I delete dll files I have another type of error...).

Can you help me ?
Posts: 9
Joined: Fri Dec 10, 2010 5:42 pm

Re: Can't load template in 64 bit version

Postby IDEAL Software Support » Tue Dec 05, 2017 1:41 pm

Please send zipped sample project to our support e-mail address.
IDEAL Software Support
Posts: 1555
Joined: Thu Nov 18, 2004 4:03 pm

Return to VPE Open Forum

Who is online

Users browsing this forum: Google [Bot] and 8 guests