Can't Deploy ActiveX - COM Licensing

regarding the VPE Report Engine and PDF Library

Moderator: IDEAL Software Support

Can't Deploy ActiveX - COM Licensing

Postby IDEAL Software Support » Thu Dec 16, 2004 4:43 pm

I use the VPE ActiveX and it works fine. But when I install my application on my end user's client machines, the demo banners are shown or I get OLE / COM Licensing errors.

A: The COM Licensing works as follows:
When you place a VPE ActiveX at design time - when you are developing your application - on your forms, the server (your programming tool) requests your personal VPE License Key from the ActiveX client and stores it together with the form.

If you later build your executable or deliverable application for shipment to your clients, the *encrypted* VPE License Key is automatically stored by your development tool within your application. Furthermore, the License Key is marked as "executable only", this means the ActiveX can not be used on the target machine for development purposes.
If you get the demo banner in VPE or any OLE License error codes regarding VPE when running your application, then something with the COM Licensing went wrong.

Visual Basic has no such problems, but we heard that Visual FoxPro, Progress and Centura request the License Key only once from a newly inserted ActiveX and then keep it. This means that if you use the VPE ActiveX with the demo version or with a specific VPE Edition (Standard, Enhanced, Professional, etc.), and install later the full version or another Edition, you need to delete the ActiveX controls from your application and re-insert them, so the new License Key is updated by your development tool. This is solely a problem of the development tool you are using - as mentioned before, Visual Basic for example has no such problems.
IDEAL Software Support
 
Posts: 1589
Joined: Thu Nov 18, 2004 4:03 pm

Return to VPE Frequently Asked Questions

Who is online

Users browsing this forum: No registered users and 2 guests

cron